Requested action not taken. Concatenated Get in Deflated mod - WeOnlyDo Discussion board

Requested action not taken. Concatenated Get in Deflated mod (wodFtpDLX / wodFtpDLX.NET)

by Steve Haney, Wednesday, May 23, 2018, 22:31 (145 days ago)

For a specific FTP server that we download files from we started to get an error a few days ago:

Requested action not taken. Concatenated Get in Deflated mode is not supported.

The full stack is:

An exception occurred while trying to download files from: /outgoing
Message: Requested action not taken. Concatenated Get in Deflated mode is not supported
Source: WeOnlyDo.Client.FTP
at WeOnlyDo.Protocols.FTP._GetFile()
at WeOnlyDo.Client.FtpDLX.GetFile(String LocalPath, String RemotePath)

The Ftp server is using FTP protocol on port 21. The code calling GetFile is pretty simple. This has worked for over a year without issues and I'm trying to determine if its the host FTP server that might've changed something. I don't even see where deflated mode is an option.

Code calling GetFile...


log.DebugFormat("Downloading remote file: {0}, Modification Date: {1} {2} UTC, Size: {3} bytes", fullPath, item.ModificationTime.ToUniversalTime().ToShortDateString(), item.ModificationTime.ToUniversalTime().ToShortTimeString(), item.Size);
 ftp.GetFile(downloadDirectory, fullPath);

Log shows the full path looks to be valid...
Downloading remote file: /outgoing/ARPP.BACLR.CA.CATHAIMS.A00.180522051300.asc, Modification Date: 5/22/18 10:13 AM UTC, Size: 881 bytes

We're using blocking mode but other than that there aren't any unique properties.

Requested action not taken. Concatenated Get in Deflated mod

by wodSupport, Wednesday, May 23, 2018, 22:33 (145 days ago) @ Steve Haney

Hi Steve.

If you set Compression to 0, does it work?

Jasmine.

Requested action not taken. Concatenated Get in Deflated mod

by Steve Haney, Wednesday, May 23, 2018, 22:46 (145 days ago) @ wodSupport

Hi Steve.

If you set Compression to 0, does it work?

Jasmine.

No that didn't seem to make a difference. Is there a way to get a verbose log to file using FtpDlx.net?

I used WinScp client and that connects fine. Here are the logs from that tool.

Initial Connection. MODE Z is mentioned which I thought means the server supports the Deflate mode, but maybe I'm reading that wrong.


. 2018-05-23 11:43:01.529 Connecting to b2b21.bankofamerica.com ...
. 2018-05-23 11:43:01.646 Connected with b2b21.bankofamerica.com. Waiting for welcome message...
< 2018-05-23 11:43:01.698 220 Server ready for new user.
[quote]2018-05-23 11:43:01.698 USER cathaims[/quote]
< 2018-05-23 11:43:01.746 331 Password required for cathaims.
[quote]2018-05-23 11:43:01.746 PASS ********[/quote]
< 2018-05-23 11:43:01.833 230 User cathaims logged in.
[quote]2018-05-23 11:43:01.833 SYST[/quote]
< 2018-05-23 11:43:01.876 215 UNIX Type: A
[quote]2018-05-23 11:43:01.876 FEAT[/quote]
< 2018-05-23 11:43:01.919 211-Extensions supported:
< 2018-05-23 11:43:01.919  AUTH
< 2018-05-23 11:43:01.919  CCC
< 2018-05-23 11:43:01.919  EPRT
< 2018-05-23 11:43:01.919  EPSV
< 2018-05-23 11:43:01.919  FEAT
< 2018-05-23 11:43:01.919  MDTM
< 2018-05-23 11:43:01.919  PBSZ
< 2018-05-23 11:43:01.919  SIZE
< 2018-05-23 11:43:01.919  REST STREAM
< 2018-05-23 11:43:01.919  MODE Z
< 2018-05-23 11:43:01.919 211 End
. 2018-05-23 11:43:01.942 Connected

File Transfer


. 2018-05-23 11:43:17.836 [Background 1] Copying 1 files/directories to local directory "C:\code\" - in parallel, with 1 total files - total size: 881
. 2018-05-23 11:43:17.837 [Background 1]   PrTime: Yes; PrRO: No; Rght: rw-r--r--; PrR: No (No); FnCs: N; RIC: 0100; Resume: S (102400); CalcS: Yes; Mask: *.*
. 2018-05-23 11:43:17.837 [Background 1]   TM: B; ClAr: No; RemEOF: No; RemBOM: No; CPS: 0; NewerOnly: No; InclM: ; ResumeL: 0
. 2018-05-23 11:43:17.837 [Background 1]   AscM: *.*html; *.htm; *.txt; *.php; *.php3; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; *.js; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
. 2018-05-23 11:43:17.837 [Background 1] File: '/outgoing/ARPP.BACLR.CA.CATHAIMS.A00.180522051300.asc' [2018-05-22T09:13:00.000Z] [881]
. 2018-05-23 11:43:17.837 [Background 1] Copying "/outgoing/ARPP.BACLR.CA.CATHAIMS.A00.180522051300.asc" to local directory started.
. 2018-05-23 11:43:17.837 [Background 1] Binary transfer mode selected.
. 2018-05-23 11:43:17.837 [Background 1] Starting download of /outgoing/ARPP.BACLR.CA.CATHAIMS.A00.180522051300.asc
[quote]2018-05-23 11:43:17.838 [Background 1] TYPE I[/quote]
< 2018-05-23 11:43:17.888 [Background 1] 200 Type set to I.
[quote]2018-05-23 11:43:17.888 [Background 1] PASV[/quote]
< 2018-05-23 11:43:17.934 [Background 1] 227 Entering Passive Mode (171,162,110,11,89,240)
[quote]2018-05-23 11:43:17.935 [Background 1] RETR ARPP.BACLR.CA.CATHAIMS.A00.180522051300.asc[/quote]
. 2018-05-23 11:43:17.935 [Background 1] Connecting to 171.162.110.11:23024 ...
. 2018-05-23 11:43:17.965 Session upkeep
< 2018-05-23 11:43:18.016 [Background 1] 125 Data connection already open; transfer starting.
. 2018-05-23 11:43:18.067 [Background 1] Data connection closed
< 2018-05-23 11:43:18.070 [Background 1] 226 Closing data connection, Binary transfer complete.
. 2018-05-23 11:43:18.070 [Background 1] Preserving timestamp [2018-05-22T09:13:00.000Z]
. 2018-05-23 11:43:18.076 [Background 1] Download successful
. 2018-05-23 11:43:18.076 [Background 1] Got reply 1 to the command 4
. 2018-05-23 11:43:18.077 [Background 1] Transfer done: '/outgoing/ARPP.BACLR.CA.CATHAIMS.A00.180522051300.asc' => 'C:\code\ARPP.BACLR.CA.CATHAIMS.A00.180522051300.asc' [881]
. 2018-05-23 11:43:18.077 [Background 1] Copying finished: Transferred: 881, Elapsed: 0:00:00, CPS: 13,984/s

Requested action not taken. Concatenated Get in Deflated mod

by wodSupport, Wednesday, May 23, 2018, 22:51 (145 days ago) @ Steve Haney

Hi Steve,

yes, I think MODE Z is the problem here. You can use FTPReply event to get full log of what's sent/received to the server

/FtpDLX.NET/Help/wodFtpDLX.NET-WeOnlyDo.Client.FtpDLX-FtpReplyEvent-event.html

Error you're getting could be related to using Resume property set to True, and Compression set to non-zero. Otherwise I'm not sure why it would be returned.

Jasmine.

Requested action not taken. Concatenated Get in Deflated mod

by Steve Haney, Wednesday, May 23, 2018, 23:01 (145 days ago) @ wodSupport

Hi Steve,

yes, I think MODE Z is the problem here. You can use FTPReply event to get full log of what's sent/received to the server

/FtpDLX.NET/Help/wodFtpDLX.NET-WeOnlyDo.Client.FtpDLX-FtpReplyEvent-event.html

Error you're getting could be related to using Resume property set to True, and Compression set to non-zero. Otherwise I'm not sure why it would be returned.

Jasmine.

I'll hook up that event and include that in the the thread. Other than setting Blocking = true, I wasn't setting any other properties.

I am trying Compression = 0, but should I also change the Resume property based on your mention?

Requested action not taken. Concatenated Get in Deflated mod

by wodSupport, Wednesday, May 23, 2018, 23:07 (145 days ago) @ Steve Haney

Hi Steve,

Blocking should make no difference (it makes difference how your local side works, not the server interaction).

Resume should be False. Compression should be 0, make sure it's set like that before calling the Connect method.

Jasmine.

Requested action not taken. Concatenated Get in Deflated mod

by Steve Haney, Wednesday, May 23, 2018, 23:15 (145 days ago) @ wodSupport

Hi Steve,

Blocking should make no difference (it makes difference how your local side works, not the server interaction).

Resume should be False. Compression should be 0, make sure it's set like that before calling the Connect method.

Jasmine.

I tried adding the Event Delegator but it doesn't seem to be logging. Regardless it does seem that the combination of Compression = 0 and Resume = False worked.

For this to break out of the blue do you think the Server host had to change some configuration on their end? I'm also assuming that I probably don't want to use Compression 0, Resume False for every single other FTP connection with other clients. Do you recommend these only get set to 0/false in cases where this error is encountered?

Thanks

Requested action not taken. Concatenated Get in Deflated mod

by wodSupport, Wednesday, May 23, 2018, 23:16 (145 days ago) @ Steve Haney

Hi Steve,

why not? Use Compression = 0, since you can live just nice with no compression on today's speeds. As for Resume = false - you will always download full files. When dealing with important files, it could be safer way to go.

Jasmine.

Requested action not taken. Concatenated Get in Deflated mod

by Steve Haney, Wednesday, May 23, 2018, 23:51 (145 days ago) @ wodSupport

Hi Steve,

why not? Use Compression = 0, since you can live just nice with no compression on today's speeds. As for Resume = false - you will always download full files. When dealing with important files, it could be safer way to go.

Jasmine.

Thank you for your help!