Semd mail using gmail SMTP server - WeOnlyDo Discussion board

Semd mail using gmail SMTP server (wodSmtp)

by JohnW, Monday, June 01, 2009, 11:34 (5500 days ago)

Hi,

I am currently evaluating the wodSMTP Active X control.
I tried the example in Delphi exactly as it came and it worked for me.
I then ported it into my own program, and again it worked.

Line of code:

wodSMTP1.SendSimpleAttachment('xxxxx@gmail.com','yyyyy@asl-solutions.co.uk','Test message','This is just a test message','C:MCCDATA' + sRTFFileName);

But when I put in the various properties as specified in previous questions and answers, it failed. This is what came up in the Memo box:

Starting to send
Connecting to the server.
Connecting to: smtp.gmail.com

Negotiating SSL encryption.
Established SSL encryption.
Sending greeting to the server.
Connected to the server.
Connected
Sending MAIL FROM command.
Connected to the server.
Not connected.
DISCONNECTED
Done : 5.5.1 http://mail.google.com/support/bin/answer.py?answer=14257 24sm7044766eyx.23
Disconnected, will retry.
Connecting to the server.
Connecting to: smtp.gmail.com
Negotiating SSL encryption.
Established SSL encryption.
Sending greeting to the server.
Connected to the server.
Connected
Sending MAIL FROM command.
Connected to the server.
Not connected.
DISCONNECTED
Done : 5.5.1 http://mail.google.com/support/bin/answer.py?answer=14257 28sm7071280eye.26
Disconnected, will retry.

After that I copied the contents f the box and reset the prog.

Question is How can it work with minimal info but fail when correct info put in?

I use Outlook normally and have Gmail as my default. But the end-user does not use Outlook - only Gmail from within IE


Complete thread: