Wodwebserver cookies and Safari - WeOnlyDo Discussion board

Wodwebserver cookies and Safari (wodWebServer / wodWebServer.NET)

by amirsky, Sunday, May 09, 2010, 22:43 (3751 days ago)

Hey I am having a major problem as Mac's Safari is not maintaining the the wod session cookie. I see five cookies get listed in firefox and IE. WODSESSIONID and four __utm<x> cookies. However in Mac Safari only the four __utm<x> are created. WODSESSIONID is not which subsequently causes the user to get logged out because their session data is lost.

Like I said, things work fine with Firefox and IE. Even Firefox on a Mac. But Mac Safari is having this issue. I read up that Safari is very strict on how the cookies are formatted and if it strays from the standard it rejects the cookie outright.

Can you shed any light on what is going on and how to resolve the issue? I will try to get more details.

Re: Wodwebserver cookies and Safari

by woddrazen, Monday, May 10, 2010, 00:46 (3751 days ago) @ amirsky

Hi Amirsky,


Is there any chance you can show us some code snippet you are using in wodWebServer for sending session cookies to clients? Or maybe you can send us some sample that will duplicate it?

Does this problem occur only in Safari on Mac OS? Did you maybe try Safari for Windows OS or Google Chrome? What happens there?

Sorry for all my questions but we have to isolate your problem somehow and try to resolve it.


Regards,
Drazen

Re: Wodwebserver cookies and Safari

by amirsky, Monday, May 10, 2010, 11:22 (3750 days ago) @ woddrazen

I'll work in a sample though I'd be more comfortable sending it be email.

We tested on Safari for Windows and Google Chrome and they work fine.

We are experiencing the error on Mac OSX 10.6.2 with Safari 4.0.3

Re: Wodwebserver cookies and Safari

by wodDamir, Monday, May 10, 2010, 11:25 (3750 days ago) @ amirsky

Hi,

Sure, you can send a sample to techsupport@weonlydo.com

Regards,
Damba