Could not load file or assembly 'WeOnlyDo.Security.Crypto... - WeOnlyDo Discussion board

Could not load file or assembly 'WeOnlyDo.Security.Crypto... (wodSSH / wodSSH.NET)

by madmaats, Monday, August 17, 2015, 21:07 (1753 days ago)


I'm getting this error on the server where the code should be hosted: Could not load file or assembly 'WeOnlyDo.Security.Cryptography.KeyManager.dll' or one of its dependencies...

The code works fine on my dev environment, but not on the server where it should be hosted.

I have now created a very simple console app with this code to make sure nothing else is the problem:
WeOnlyDo.Security.Cryptography.KeyManager km = new WeOnlyDo.Security.Cryptography.KeyManager();

I have tried both the 64bit and the 32 bit version (compiled with x64 and x86), but I get the same error all the time on the server.
It works perfectly fine on my dev machine.

I'm using the .net 4 version of WeOnlyDo.Security.Cryptography.KeyManager.dll (and compiling it for .net 4.

When testing the .net 2 version and compiling it for .net 2 it works fine. Both x86 and x64.
Unfortunately I can't use .net 2 for my project, so this is not an option.

Must be some dependency missing for the .net 4 version on the server. What dependencies does the WeOnlyDo.Security.Cryptography.KeyManager have?


Complete thread: