Port Forwarding - WeOnlyDo Discussion board

Port Forwarding (wodSSHServer)

by AP, Wednesday, June 22, 2011, 13:47 (2341 days ago)

Facing problem while taking RDP using C2S port forwarding.

i have 2 XP machines.
On one machine we have installed wodSSH server and on another machine tunnelier client.
From tunnelier client m/c have successfully connected to SSHSever and forwarded port 3389
(Listen on 127.0.0.1 port 3387 Destination Host-localhost and port – 3389)

After connection when i take remote control using
mstsc 127.0.0.1:3387

RDP window open with login screen but after entering credentials only black screen open.

Can you please help me in resolving the same?

Re: Port Forwarding

by wodDamir, Wednesday, June 22, 2011, 14:10 (2341 days ago) @ AP

Hi AP,

What user are you logging in? Can you try logging a different user then the one that is running wodSSHServer?

Regards,
Damba

Re: Port Forwarding

by AP, Wednesday, June 22, 2011, 15:50 (2341 days ago) @ wodDamir

I tried with different user and also under local sys account but the same problem.

Re: Port Forwarding

by wodDamir, Wednesday, June 22, 2011, 17:06 (2341 days ago) @ AP

AP,

Did you try any other SSH Server that doesn't install it self as a service??

Regards,
Damba

Re: Port Forwarding

by AP, Friday, June 24, 2011, 09:42 (2339 days ago) @ wodDamir

I tried with other SSH server (freeSSHd) and RDP is working correctly with freeSSHd.

Re: Port Forwarding

by woddrazen, Friday, June 24, 2011, 12:32 (2339 days ago) @ AP

Hi,


This worked for me without any problem. I'm using two Windows XP SP3 machines.

On side where is wodSSHServer I created one more user. On other side I connected using tunnelier and RDP to second (one that is not running wodSSHServer) user and it worked without any issue.

Are you sure that you do same on your side?

If you don't want to user another user for RDP, you need to run wodSSHServer and system service.


Drazen

Re: Port Forwarding

by AP, Friday, June 24, 2011, 15:20 (2339 days ago) @ woddrazen

Drazen,

Yes, we are doing the same thing at our end. only difference is we have one xp sp2 and other XP SP3 and also we are using trial version of wodSSH.

Machine 1. already logged on with user(admin). Started SSHServer under
another user (User1) by Run as.

Machine 2. Started Tunnelier connected to SSHServer and port forwarded. listen 127.0.0.1:3387 destination host machine1 and port 3389.

started mstsc 127.0.0.1:3387 on machine 2

login screen promped. Enter the login details(admin user)
----only black screen appears after some time below mention message popup and on tunnelier Server disconnected without sending disconnect message comes.


---------------------------
Remote Desktop Disconnected
---------------------------
This computer can't connect to the remote computer.

The two computers couldn't connect in the amount of time allotted. Try connecting again. If the problem continues, contact your network administrator or technical support.
---------------------------

Re: Port Forwarding

by wodDamir, Friday, June 24, 2011, 15:39 (2339 days ago) @ AP

AP,

Can you please try actually running wodSSHServer directly (not by doing Run As, but switching the user), and log on the different user?

Regards,
Damba