proxytype error? - WeOnlyDo Discussion board

proxytype error? (wodSSHServer)

by bonghwan, Monday, August 03, 2009, 08:23 (3031 days ago)

Hi,

i used wodTunnel.dll(v1.6.1.68)
i want to ftp proxy. but the setting socks5 type is occur error at compile time. the error message is 'no error'.

i attached my code snippet.

private sub Proxyconnect()
tunnel.Login = joe
tunnel.Password = joe
tunnel.Timeout = 60
tunnel.Protocol = ProtocolsEnum.SSHAuto
tunnel.ProxyType = ProxyTypes.ProxySocks5
tunnel.Connect(_SSH_SERVER_IP, _SSH_SERVER_PORT)
end sub

private sub StartChannel()
tunnel.Channels.Add(wodSSHTunnelCOMLib.ForwardTypesEnum.SocksProxy, , 9999, , )
tunnel.Channels.StartAll()
end sub

regards,

Re: proxytype error?

by wodDamir, Monday, August 03, 2009, 10:32 (3031 days ago) @ bonghwan

Bonghwan,

Can you please explain what exactly is is that you want to accomplish?

You didn't specify ProxyHostName property, so that's most probably the reason the error is thrown.

Regards,
Damba

Re: proxytype error?

by bonghwan, Monday, August 03, 2009, 11:23 (3031 days ago) @ wodDamir

hi damba,

i want to FTP-proxy service with wodTunnel.dll.
so, can you send me for sample?

regards,

Re: proxytype error?

by wodDamir, Monday, August 03, 2009, 11:55 (3031 days ago) @ bonghwan

Bonghwan,

I assume you want SSHTunnel to act as SocksProxy server. If so, you should remove ProxyType property from your code.

Just connect to your SSH Server, and then connect your FTP client to machine that is running SSHTunnel. That shoul be it.

Can you please try that?

Regards,
Damba

Re: proxytype error?

by BongHwan, Monday, August 03, 2009, 13:18 (3031 days ago) @ wodDamir

Hi Damba,

Our test environment is that
ftp user -> our proxy tunnel(wodtunnel.dll) -> ftp server.

We set socks5 in a ftp client(filezilla) on user side.

What is happened is that
when a user upload or download a file, Transfer complete message is returned before the file is really transferred.

These are messages during the time:
status: connecting to 192.168.1.1:9902
status: Connection with proxy established, performing handshake...
response: 150 Opening BINARY mode data connection for 'file.exe'.
response: 226 Transfer complete.

Regards,

Re: proxytype error?

by wodDamir, Monday, August 03, 2009, 14:35 (3031 days ago) @ BongHwan

Bonghwan,

Ok, but I'm not really sure that this is caused by tunnnel?

The connection was open correctly, communication was going ok. At some stage, the server sent 226 Transfer complete , which client did receive.

I also tried the same on our sample (1. Simple) with only changing the SSH_1.Channels.Add line to SSH_1.Channels.Add wodSSHTunnelCOMLib.ForwardTypesEnum.SocksProxy, , 8080 . It worked like a charm.

Does it work with any other proxy?

Regards,
Damba

Re: proxytype error?

by BongHwan, Tuesday, August 04, 2009, 04:35 (3030 days ago) @ wodDamir

Hi,

I tested with your code in the same way. Yes. It works fine only when I use a general SSH Server in Linux.
But, when I use a wodSSHServer component as a SSH Server, I can see the same wrong result.

I think there is a troble in the wodSSHServer component to handle this. How about you?


Regards,
BongHwan.

Re: proxytype error?

by wodDamir, Tuesday, August 04, 2009, 09:50 (3030 days ago) @ BongHwan

Bonghwan,

How did you test using wodSSHServer? Did you use our sample?

I tried using our 1. Basic sample, which worked correctly. I did have to remove code from ServiceStart event, and allow services (simply set Action = Allow in ServiceRequest event) but after that it worked like a charm.

Can you try the same?

Regards,
Damba